Переходим с Firefox 1.0.7 на Firefox 1.5

При переходе с 1.0.7 на 1.5 могут возникнуть проблемы с некоторыми расширениями. Проблема заключается в том, что в списке расширений напротив некоторых может быть надпись следующего содержания (текст не точный): "Данное расширение не может быть установлено, т.к. оно не совместимо с версией Firefox 1.5. Если обновлений для данного и под эту версию браузера обновлений нет, а само расширение очень вам нужно (привыкли, удобно), то можно поступить следующим образом.

Для начала, если необходимое расширение вы не качали и оно не лежит у вас на жёстком диске, надо скачать нужное расширение. Затем открыть его в любом архиваторе, который понимает и может работать с zip-архивами (да, да, расширение не что иное, как простой zip-архив). Как вариант, сначала можно переименовать расширение, например, cutemenus-0.4-fx.xpi в cutemenus-0.4-fx.zip. После того как вы открыли в архиваторе нужное расширение, надо найти файл install.rdf и открыть его в любом текстовом редакторе (только не MS Word emoticon). Сам файл представляет собой просто xml-файл, поэтому ищем строку (к рассматриваемому расширению CuteMenus) <em:maxVersion>1.0</em:maxVersion> и заменяем её на <em:maxVersion>1.5</em:maxVersion>. Сохраняем файл install.rdf, закрываем архив. Если архиватор спросит о переупаковке (у меня не спрашивал), отвечайте положительно. Если вы переименовывали файл в zip, обратно переименуйте его в xpi. Всё. Теперь можно спокойно устанавливать расширение.

Подобным образом поступаем со всеми расширениями, которым не нравится ваша версия Firefox и для которых нет более свежих версий. 

Переходим с Firefox 1.0.7 на Firefox 1.5: 1 комментарий

Обсуждение закрыто.